Printer Forums

Printer Forums - Printing Help and Support > Newsgroups > Printer Newsgroups > Printers > Canon PIXMA MG3122 problems

Reply
Thread Tools Display Modes

Canon PIXMA MG3122 problems

 
 
KenK
Guest
Posts: n/a

 
      08-07-2012, 09:36 PM
I just installed my new Canon PIXMA MG3122 printer. It uses a USB
connection. It seems to work fine. However, if I turn it on my two USB disk
drives, an external and a flash drive, disappear from my system. Say "Drive
not found" if I try to use either. If I turn the printer off they do not
return until I reboot.

I looked but can't find any Canon newsgroups so am asking here.

Can anyone help? As soon as I have time I'm going to try Canon's web site,
assuming it exists, and Google.

Thanks on advance for any help. Surely I'm not the only one that has had
this problem.

FWIW I'm using XP home, USB 2.0 and SP 2.

Ken


--
"Where there's smoke there's toast!" Anon





 
Reply With Quote
 
 
 
 
KenK
Guest
Posts: n/a

 
      08-08-2012, 04:45 PM
"David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in
news: :

> From: "KenK" <>
>
>> I just installed my new Canon PIXMA MG3122 printer. It uses a USB
>> connection. It seems to work fine. However, if I turn it on my two
>> USB disk
>> drives, an external and a flash drive, disappear from my system. Say
>> "Drive
>> not found" if I try to use either. If I turn the printer off they do
>> not return until I reboot.
>>
>> I looked but can't find any Canon newsgroups so am asking here.
>>
>> Can anyone help? As soon as I have time I'm going to try Canon's web
>> site, assuming it exists, and Google.
>>
>> Thanks on advance for any help. Surely I'm not the only one that has
>> had this problem.
>>
>> FWIW I'm using XP home, USB 2.0 and SP 2.
>>
>> Ken
>>

>
> Sounds like the internal USB root hub (chip-set) is bad.
>
> I suggest getting an external, powered, USB 2.0 hub and hooking up the
> periphery through it or take advantage of WiFi connectivity if you
> have a WiFi capable SOHO Router.
>


Thanks. Just bought a powered hub. Will try it later today or tomorrow
first thing. I'll let you know results.

Ken


--
"Where there's smoke there's toast!" Anon





 
Reply With Quote
 
 
 
 
Rob
Guest
Posts: n/a

 
      08-08-2012, 11:28 PM
On 9/08/2012 2:45 AM, KenK wrote:
> "David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in
> news: :
>
>> From: "KenK" <>
>>
>>> I just installed my new Canon PIXMA MG3122 printer. It uses a USB
>>> connection. It seems to work fine. However, if I turn it on my two
>>> USB disk
>>> drives, an external and a flash drive, disappear from my system. Say
>>> "Drive
>>> not found" if I try to use either. If I turn the printer off they do
>>> not return until I reboot.
>>>
>>> I looked but can't find any Canon newsgroups so am asking here.
>>>
>>> Can anyone help? As soon as I have time I'm going to try Canon's web
>>> site, assuming it exists, and Google.
>>>
>>> Thanks on advance for any help. Surely I'm not the only one that has
>>> had this problem.
>>>
>>> FWIW I'm using XP home, USB 2.0 and SP 2.
>>>
>>> Ken
>>>

>>
>> Sounds like the internal USB root hub (chip-set) is bad.
>>
>> I suggest getting an external, powered, USB 2.0 hub and hooking up the
>> periphery through it or take advantage of WiFi connectivity if you
>> have a WiFi capable SOHO Router.
>>

>
> Thanks. Just bought a powered hub. Will try it later today or tomorrow
> first thing. I'll let you know results.
>
> Ken
>
>


There is a fixit solution on the Microsoft site for the USB root hub.
You may have to google it up.
 
Reply With Quote
 
KenK
Guest
Posts: n/a

 
      08-10-2012, 04:56 PM
"David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in
news: :

> From: "KenK" <>
>
>> I just installed my new Canon PIXMA MG3122 printer. It uses a USB
>> connection. It seems to work fine. However, if I turn it on my two
>> USB disk
>> drives, an external and a flash drive, disappear from my system. Say
>> "Drive
>> not found" if I try to use either. If I turn the printer off they do
>> not return until I reboot.
>>
>> I looked but can't find any Canon newsgroups so am asking here.
>>
>> Can anyone help? As soon as I have time I'm going to try Canon's web
>> site, assuming it exists, and Google.
>>
>> Thanks on advance for any help. Surely I'm not the only one that has
>> had this problem.
>>
>> FWIW I'm using XP home, USB 2.0 and SP 2.
>>
>> Ken
>>

>
> Sounds like the internal USB root hub (chip-set) is bad.
>
> I suggest getting an external, powered, USB 2.0 hub and hooking up the
> periphery through it or take advantage of WiFi connectivity if you
> have a WiFi capable SOHO Router.
>


Powered USB hub in the printer line seems to have solved the problem.

Thanks.


--
"Where there's smoke there's toast!" Anon





 
Reply With Quote
 
 
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pixma mg3122 drgood Canon 1 07-30-2013 07:26 PM
Canon Pixma IP 1500 " Problems pete Canon 3 05-16-2006 04:43 PM
Canon Pixma ip 3000 problems is there a master reset? dazlear Canon 1 03-26-2006 08:06 PM
Installation problems - Canon Pixma IP 4000 R dirkt Canon 2 05-23-2005 02:39 PM
Canon Pixma IP4000 R - Installation problems Dirkt Canon 1 05-22-2005 07:32 AM