Canon PIXMA MG3122 problems

Discussion in 'Printers' started by KenK, Aug 7, 2012.

  1. KenK

    KenK Guest

    I just installed my new Canon PIXMA MG3122 printer. It uses a USB
    connection. It seems to work fine. However, if I turn it on my two USB disk
    drives, an external and a flash drive, disappear from my system. Say "Drive
    not found" if I try to use either. If I turn the printer off they do not
    return until I reboot.

    I looked but can't find any Canon newsgroups so am asking here.

    Can anyone help? As soon as I have time I'm going to try Canon's web site,
    assuming it exists, and Google.

    Thanks on advance for any help. Surely I'm not the only one that has had
    this problem.

    FWIW I'm using XP home, USB 2.0 and SP 2.

    Ken


    --
    "Where there's smoke there's toast!" Anon
     
    KenK, Aug 7, 2012
    #1
    1. Advertising

  2. KenK

    KenK Guest

    "David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in
    news::

    > From: "KenK" <>
    >
    >> I just installed my new Canon PIXMA MG3122 printer. It uses a USB
    >> connection. It seems to work fine. However, if I turn it on my two
    >> USB disk
    >> drives, an external and a flash drive, disappear from my system. Say
    >> "Drive
    >> not found" if I try to use either. If I turn the printer off they do
    >> not return until I reboot.
    >>
    >> I looked but can't find any Canon newsgroups so am asking here.
    >>
    >> Can anyone help? As soon as I have time I'm going to try Canon's web
    >> site, assuming it exists, and Google.
    >>
    >> Thanks on advance for any help. Surely I'm not the only one that has
    >> had this problem.
    >>
    >> FWIW I'm using XP home, USB 2.0 and SP 2.
    >>
    >> Ken
    >>

    >
    > Sounds like the internal USB root hub (chip-set) is bad.
    >
    > I suggest getting an external, powered, USB 2.0 hub and hooking up the
    > periphery through it or take advantage of WiFi connectivity if you
    > have a WiFi capable SOHO Router.
    >


    Thanks. Just bought a powered hub. Will try it later today or tomorrow
    first thing. I'll let you know results.

    Ken


    --
    "Where there's smoke there's toast!" Anon
     
    KenK, Aug 8, 2012
    #2
    1. Advertising

  3. KenK

    Rob Guest

    On 9/08/2012 2:45 AM, KenK wrote:
    > "David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in
    > news::
    >
    >> From: "KenK" <>
    >>
    >>> I just installed my new Canon PIXMA MG3122 printer. It uses a USB
    >>> connection. It seems to work fine. However, if I turn it on my two
    >>> USB disk
    >>> drives, an external and a flash drive, disappear from my system. Say
    >>> "Drive
    >>> not found" if I try to use either. If I turn the printer off they do
    >>> not return until I reboot.
    >>>
    >>> I looked but can't find any Canon newsgroups so am asking here.
    >>>
    >>> Can anyone help? As soon as I have time I'm going to try Canon's web
    >>> site, assuming it exists, and Google.
    >>>
    >>> Thanks on advance for any help. Surely I'm not the only one that has
    >>> had this problem.
    >>>
    >>> FWIW I'm using XP home, USB 2.0 and SP 2.
    >>>
    >>> Ken
    >>>

    >>
    >> Sounds like the internal USB root hub (chip-set) is bad.
    >>
    >> I suggest getting an external, powered, USB 2.0 hub and hooking up the
    >> periphery through it or take advantage of WiFi connectivity if you
    >> have a WiFi capable SOHO Router.
    >>

    >
    > Thanks. Just bought a powered hub. Will try it later today or tomorrow
    > first thing. I'll let you know results.
    >
    > Ken
    >
    >


    There is a fixit solution on the Microsoft site for the USB root hub.
    You may have to google it up.
     
    Rob, Aug 9, 2012
    #3
  4. KenK

    KenK Guest

    "David H. Lipman" <DLipman~nospam~@Verizon.Net> wrote in
    news::

    > From: "KenK" <>
    >
    >> I just installed my new Canon PIXMA MG3122 printer. It uses a USB
    >> connection. It seems to work fine. However, if I turn it on my two
    >> USB disk
    >> drives, an external and a flash drive, disappear from my system. Say
    >> "Drive
    >> not found" if I try to use either. If I turn the printer off they do
    >> not return until I reboot.
    >>
    >> I looked but can't find any Canon newsgroups so am asking here.
    >>
    >> Can anyone help? As soon as I have time I'm going to try Canon's web
    >> site, assuming it exists, and Google.
    >>
    >> Thanks on advance for any help. Surely I'm not the only one that has
    >> had this problem.
    >>
    >> FWIW I'm using XP home, USB 2.0 and SP 2.
    >>
    >> Ken
    >>

    >
    > Sounds like the internal USB root hub (chip-set) is bad.
    >
    > I suggest getting an external, powered, USB 2.0 hub and hooking up the
    > periphery through it or take advantage of WiFi connectivity if you
    > have a WiFi capable SOHO Router.
    >


    Powered USB hub in the printer line seems to have solved the problem.

    Thanks.


    --
    "Where there's smoke there's toast!" Anon
     
    KenK, Aug 10, 2012
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dirkt
    Replies:
    1
    Views:
    346
  2. dirkt
    Replies:
    2
    Views:
    238
    Arthur Entlich
    May 23, 2005
  3. dazlear
    Replies:
    1
    Views:
    309
  4. drgood

    pixma mg3122

    drgood, Jan 9, 2013, in forum: Canon
    Replies:
    1
    Views:
    528
    l_d_allan
    Jul 30, 2013
  5. KenK

    Canon Pixma MG3122 problem

    KenK, Jul 20, 2013, in forum: Printers
    Replies:
    6
    Views:
    501
    ps56k
    Jul 28, 2013
Loading...

Share This Page