Epson L3151 printer installed as L2710

Discussion in 'Printer Drivers' started by Georgijevic, Jun 6, 2019.

  1. Georgijevic

    Georgijevic

    Joined:
    Jun 6, 2019
    Messages:
    1
    Likes Received:
    0
    Hi, I'm Miroslav and I'm from Serbia.

    I'm facing an issue with Epson L3151 printer. It worked fine for few week after I bought it, but now Windows keeps instaling L2710 printer, so I can't reach Wi-Fi and other functions.


    When I try to install official software, driver... Win can't find the printer in the part when you choosing Wi-Fi or USB cable connection...

    I tried on two different Windows 10 computers and having the same issue. Looks like the firmware in the printer is installed wrongly and I can't get to it now.

    I also can't turn on wi-fi on the printer.

    I would highly appreciate any help.

    Thanks,
    Miroslav
     
    Georgijevic, Jun 6, 2019
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.