Ricoh 1832 and 1852 refusing to print any document sent to them

Discussion in 'Ricoh' started by InfoprintNewbie, Apr 12, 2016.

  1. InfoprintNewbie

    InfoprintNewbie

    Joined:
    Apr 12, 2016
    Messages:
    1
    Likes Received:
    0
    Hello,

    On two laptops coming with Windows 7, I installed the 64-bit version of Ricoh's PCL and PostScript drivers for two monochrome laser printers that I have, a 1852dtn and a 1832tn.
    The drivers were downloaded from the official page:
    http://support.rpp.ricoh-usa.com/internet/dcfdata.nsf/vwWeb/P4000975

    The printers are detected, and some document is sent to them and visible in the printing queue.
    However the printing of the document doesn't start.
    The printers were warning about lack of paper ; hence, I added about 250 A4 sheets in both trays of each printer.
    Some maintenance menu is shown, were I can check that both the toner and the maintenance kit are ok.
    There is also a "Ready" entry in the maintenance menu.
    I tried to validate this entry but nothing happens.
    It is as the printers remained frozen in "no paper mode", despite paper was added.

    I tried to shut the printers down, to cancel the document and start the printing again, but nothing happens.

    However, using the printers menus, I can print statistics, showing that the printers themselves work.

    I'm a newbie with Ricoh. Can someone help ?

    Thanks a lot.
     
    InfoprintNewbie, Apr 12, 2016
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.