1500W Magenta fail...

Discussion in 'Epson' started by RzB, Aug 1, 2020 at 5:34 PM.

  1. RzB

    RzB

    Joined:
    Apr 18, 2014
    Messages:
    2
    Likes Received:
    0
    Location:
    UK
    I have an Epson 1500W that I was hoping to sell for Charity (Médecins Sans Frontières) - it's not had a great deal of use. I have not used it for some time but it worked fine after one head clean - nozel check fine, printed test page etc. Everything working beautifully.

    I thought it would be a good idea to replace the Light Magenta with a new cartridge, as it was very low. I have been using Compatible inks in this machine because I only needed it for making large posters etc - I have a 3880 for "fine art" stuff.

    After changing the cartridge it gave me an error - on the Magenta! (Not the one I changed). I have tried new cartridges, inspected and cleaned the contacts - all to no avail.

    I have paid the local Epson Authorised Service Center to reset the machine to Factory settings but that didn't help - looks like there really is something wrong with Magenta - not a Firmware upgrade as I thought it might be.

    I really don't want to send it to land fill - it feels like it's got years of service left in it...

    Using Windows 10.

    Any advice would be most appreciated.

    Many thanks,
    Roy
     
    RzB, Aug 1, 2020 at 5:34 PM
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.