Epson c1700 - problem with black toner

Discussion in 'Epson' started by chris1975, Jun 11, 2018.

  1. chris1975

    chris1975

    Joined:
    Jun 11, 2018
    Messages:
    1
    Likes Received:
    0
    Hi, I have the printer for 6 years, it has always worked properly but unfortunately, ultimately started to print faded with black toner, so I added a new toner and made the cleaning with the function "mix developer" that I understand agitated the toner in the cartridge.
    I tried to print again and seemed to be back ok but after a few pages started to load the toner and after a while the message "low density black toner appeared, check the cartridge installation and turn the printer off and on again ".
    Well once turned back on again to load the toner and I received another message "replace the black cartridge" because exhausted.
    What the hell happened?
    I thought maybe there was a faulty cartridge so I added another new toner, but after a while the toner loading point and headed back the message "replace toner because exhausted".
    I have read that the same problem occurs on another printer the xerox 6020 which is basically a clone of this I have, but did not come to the head of the problem.
    Both the toner that the printer gives me out of stock I installed them in another epson always c1700 that has a friend and even them me by how exhausted.
    However they are compatible and not original products just to specify it.
    Any solution?
     
    chris1975, Jun 11, 2018
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.