EPSON: WF 4630 Weird Problem


Joined
Dec 27, 2020
Messages
1
I have a few WF - 4630 printers. One is only occasionally used for office copies mostly. One day the Start/B&W/Color buttons just stopped working. I connected the printer via usb and did a firm ware update. That actually worked and commanded the printer etc. it updated successfully. I restarted the printer - sill the buttons do not work. Everything else seems to work. I used the EPSON scan software both via USB and Wireless and nothing. I cant seem to find anything on the printer buttons not working. Anyone have any ideas on this? Much appreciated!
 
Ad

Advertisements

Joined
Jul 11, 2020
Messages
71
That is somewhat odd. The control panel, pictured below, attaches through a single plug and it's not on flex wire. At this point the most likely problem culprit is a broken trace or solder joint. Do multiple people use the device? Could someone have got fed up and jammed the copy button really hard?

You'll likely have to take the board off to fix. Once you get it off, it should be obvious if it's repairable or if you need a new one. Good news is that it should be not too hard to find a replacement. I've seen them on eBay and other places.
 

Attachments

  • s-l1600.jpg
    s-l1600.jpg
    87.7 KB · Views: 12

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top