Information Regarding SX430 + Aftermarket Cartridges (No colour or missing colour)

Discussion in 'Epson' started by Skezza, Oct 13, 2013.

  1. Skezza

    Skezza

    Joined:
    Oct 13, 2013
    Messages:
    1
    Likes Received:
    0
    Hi,

    I've signed up to share my rather weird experience fixing this printer today.

    So, the printer hasn't been switched on in roughly 12 months I'd say. The main reason was a set of compatibles had been installed but it never wanted to accept the Magenta cartridge. We were constantly faced with "ink cartridge not recognized", yep that old chestnut.

    Anyway, we bought a new set of compatibles from eBay (cartridges are cheap as chips it seems) and they arrived yesterday so we decided crack on today. I installed the Magenta cartridge and the printer went through it's usual rigmarole of 'Charging' the cartridge. After a few minutes it said it was ready to print... Awesome... Not quite. I decided to run a Nozzle Check seeing as it had been off for so long I figured the printer would be unable to print it's first page clean. Surprisingly, every cartridge but magenta was fine. There was almost no colour from magenta, just a tiny little scrape which I'm fairly positive was simply leftover from the previous cartridge. I removed the cartridge and checked that it wasn't blocked or whatever and it was fine. I ran the Head Cleaner and yet, there was literally no ink coming out of the magenta cartridge whatsoever. The Head Cleaner is supposed to suck ink out, yet it sucked none whastsoever as I inspected the ink port after and there was literally no ink flow.

    Anyway, I did some reading up and I found this explanation that said the magenta colour might get blocked up due to air in the system, if it hasn't been used for a long time. Their recommended fix was to print 10 pages of pure magenta. After one page (which had 0% magenta, only a little bit of blue), the printer oddly told me that the Black cartridge was not recognized and forced me to change it. It charged, and then told me the yellow cartridge was now not recognized. I installed a new one, and sure enough, after charging, it told me the cyan cartridge was now not recognized. I changed that and it charged and it went back to the main screen, ready to print.

    I ran a nozzle check and guess what? Perfect colour from all four cartridges. Don't ask me to explain, as I haven't the foggiest but it seems some cartridges might not play nice with each other. Nothing to do with air in the system...

    Just thought this might help those with similar problems :) Chuffed it's working again, just can't understand why the cartridges didn't want to play nice :confused:
     
    Skezza, Oct 13, 2013
    #1
    1. Advertisements

  2. Skezza

    gogetink

    Joined:
    Oct 28, 2013
    Messages:
    2
    Likes Received:
    0
    Location:
    Melbourne
    Gee that must have been very frustrating at first for you. At least the printer is working now. They can be funny sort of beasts sometimes, can't they.
     
    gogetink, Oct 28, 2013
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.