Oki C9650 and bad NIC / USB port??? Help

Discussion in 'OKI' started by WePrintItAll, Dec 2, 2019.

  1. WePrintItAll

    WePrintItAll

    Joined:
    Dec 2, 2019
    Messages:
    1
    Likes Received:
    0
    Hi all,

    So I've got a C9650 Signage Oki that I've had for a few years. It's been a great printer for me, but I'm afraid it's starting to give me some issues. I'm hoping I can find a way to keep it in service another year or two.

    About 4-5 months ago, after a power outage, when I tried to print, nothing came out. Quick trouble shooting pointed to the NIC. I'm pretty well versed in computer and printer hardware and troubleshooting and sure enough, The NIC went out. I was looking online to see if I could order a new one, but on my particular model, the NIC is built in to the main motherboard. So I found a USB cable and plugged in; reset the driver and it's been working ever since......

    until today. Now it appears that I've lost the USB port on the printer. I've tried all the resets/restarts, different USB cables, different computers and NOTHING.

    I'd like to try and run a diagnostic on the USB port, but I've looked in every engineers manual; service manual, operators manual I can find and don't see anything like that.

    Anybody still on these forums that can offer a suggestion? I've got two other printers; a C9600 and an Intec CP2020 (same footprint as the C9600), so I'm not down...but this is too good of a printer to throw away.

    Thanks.
     
    WePrintItAll, Dec 2, 2019
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.