AdjProg communication error 2100012C


Joined
May 27, 2019
Messages
1
Hello Forum Community,

I hope I got the right subforum. I'm not really used to asking questions. Usually I find the solutions to my prob with searching.
Alas, this time I'm on a loss.

First some background info:
I have an Epson Stylus SX125. I got a general error. I downloaded and used WICReset to read out the error message.
The error (0xB) is not in the list of all error messages. But I'm confident that the print head is the issue.
When I opened the printer it seemed like the red ink cartridge leaked and the ink ran in the print head, where the electronics are. I already tried flushing - to no avail and fear the print head is foo bar.
I'll give it another try, soaking it two days or so in diluted alcohol (70%), but I guess I'll need a new one.
I fear the ink short circuited something on the circuit board.
But that's not why I'm posting.

I meanwhile downloaded AdjProg for Epson sx125, which seems to be the original Epson tool that I can also use for all the adjustments that, according to Epson's service manual, are necessary after removing/replacing the print head.

Which brings me to the prob:
As stated in the title, I get that communication error 2100012C
Of course I already searched and found info on error 2100012C, as well as 21000012C. The reason and the solutions don't seem to differ for the two.
I tried them all. But to make sure, here's the list:
Set port manually. When I set the port intentionally wrong, or have no printer connected, the error message differs. If this is of any interest.
Deactivated Epson Status monitor
Removed all virtual printers (Windows Fax, XPS printer, printers from .pdf creation programs), so the printer is really the only one Windows displays.
Tried compatibility mode for Windows XP SP2, WinXP SP3 and Windows 95/98/ME. Both, running the prog as Admin and not. In Win 95/98/ME it does not even find the printer. The others make no difference.
I think that's all.

The Epson utility shows that no red ink cartridge is present since I removed it. And WICReset shows the error code and allows to read serial numbers. Thus the communication with the printer basically seems to work. Just AdjProg doesn't want to.

Well, I read that since Windows Vista, Windows does not allow software to communicate directly with hardware, using its own driver rather than the Windows driver, anymore, as this was used to bypass desktop firewalls.
So I wonder if this might be the issue. And if so, how to fix. Does anybody know, if AdjProg uses the Windows driver, or brings its own driver and communicates directly with the printer?
If so, does anybody know how to fix that? I couldn't find something myself...maybe my search terms weren't good.
Or does anybody have additional ideas what might cause the issue?

Last, but not least: since I used WICReset, the Epson Status Monitor doesn't come up automatically anymore, when I connect the printer. Even though it's not deactivated. No idea if this is related. But it's the last bit of info I got.

I hope I provided all necessary information, without being too exhaustive.

Thx for your help in advance
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top