Brother DCP 8040 prints & scans OK, but copies are black

Joined
Dec 30, 2019
Messages
3
This printer prints and scans perfectly. I can scan a file to my computer, save that file, and then print the file, and I get a near-perfect copy. However, if I simply press the copy button, which obviously scans and then prints the file without sending it to the computer, I get a mess, like the picture below (that is a person's head shot in the upper right corner).

This appears to me to be some sort of software error.

Is there a way to fix this? Can this printer be reset? Does it need new firmware?

Thanks for any help.

EcX2Kmm.jpg
 
Joined
Dec 30, 2019
Messages
3
Since I can't edit my first post after a short time, I'm posting a second time.

Additional information:

If I set my scanning program to scan in B&W (grayscale or simple B&W) then I get the same result as above. However, if I set my scanning program to scan 24-bit RGB, the problem goes away and I get a good scan.

However, there is no option for color or B&W in the Copy menu (Copy is the problem I'm trying to solve). I have tried Auto, Photo, & Text (the three quality options), but the copy always looks like what you see in my first post.

I've gone through the maintenance menus, and I tried a partial initialization (MM 99) of the EEPROM, but that didn't help.

It sure seems like something in firmware got glitched and is causing the copier to scan in the wrong mode.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top