Canon Pixma MP610 bizarre problem

Discussion in 'Printer Repair' started by bananacakes, Dec 27, 2011.

  1. bananacakes

    bananacakes

    Joined:
    Dec 27, 2011
    Messages:
    1
    Likes Received:
    0
    Hi, I'm new and desperately trying to fix my printer as I need to start printing things for my wedding which is in 10 days!! help!

    I have a Canon Pixma MP610 which worked perfectly fine on my laptop (Windows Vista) but for some reason was always detected but just wouldn't print on my other half's laptop (also Windows Vista) which wasn't really a problem until I dropped my laptop on the floor!

    There can't really be much wrong with the printer as it worked fine on another machine so I'm assuming that the printer and cables are all in working order. When I attach the printer the laptop detects it and lets me select it when I want to print a document, I press print and then nothing happens. The item appears in the print queue and then disappears just like that. The laptop acts like it has sent the relevant information and the printer has received it...but nothing happens on the printer. I've tried using different ports, reinstalling new print drivers but still nothing! I've reached the end of my expertise as far as these things go and I can't think of anything else to try. Here's the funny thing though, if I go into the printer settings I can ask it to print a test page and do all the cleaning etc and it does that just fine! It just won't print documents/e-mails/pictures....anything! So the problem isn't specific to the software as I've tried and had the same result in many programs.

    If anyone has any suggestions I would be extremely grateful!

    Banana
     
    bananacakes, Dec 27, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.