Envelope Smears

Discussion in 'Printer Discussion' started by eschulze, Jul 10, 2020.

  1. eschulze

    eschulze

    Joined:
    Jul 10, 2020
    Messages:
    2
    Likes Received:
    0
    I have a Epson ET-2720 . Just bought a box of #10 business envelopes with printed return address. This printer puts ugly black smears on the envelopes. It has done this several times before but now it is worse and on every envelope. I have tried smoothing the envelope flat and only print one at a time. This is the worst printer I have ever had. Just one of several issues with it. Only about 6 months old. Can't find any info or support to solve this issue. Anyone with ideas?
     
    eschulze, Jul 10, 2020
    #1
    1. Advertisements

  2. eschulze

    PrintMaestro

    Joined:
    Jul 11, 2020
    Messages:
    11
    Likes Received:
    1
    are you running the envelop through
     
    PrintMaestro, Jul 12, 2020
    #2
    1. Advertisements

  3. eschulze

    eschulze

    Joined:
    Jul 10, 2020
    Messages:
    2
    Likes Received:
    0
    You mean through the back feeder ? Yes, it is the only place that you can load paper or envelopes that I know of. Same place as I run the letterheads through.
     
    eschulze, Jul 12, 2020
    #3
  4. eschulze

    PrintMaestro

    Joined:
    Jul 11, 2020
    Messages:
    11
    Likes Received:
    1
    Sorry, part of my post did not upload. It was supposed to say, "are you feeding through landscape or portrait orientation?" It can make a difference which way. I have a copier that will do envelopes in landscape feed but not portrait feed
     
    PrintMaestro, Jul 26, 2020
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.