EPSON WF-3620 Error code 0x69, printer head can't get to start position


Joined
May 1, 2018
Messages
1
Hello!

I am asking for advice about my WF-3620. It's 3 years old but still working good until today. Yellow color was not printing properly, so I decided to clean the head using software function. Didn't help, so I tried to change the cartridge, after changing cartridge, problem was still there, so I decided to clean the head myself. I dropped a small drop of distilled water into yellow color ink port. Then tried to print like 5 pages but nothing. So I tried next software head cleaning, which stopped in the middle of the process and popped up error code 0x69 notification, which tells me to close the cover of the cartridge and restart printer. I get that every time I start printer, so it's unusable. I opened printer and checked what's going on when starting up printer. There's some kind of white plastic carriage, which I would says blocks the way of the printer head to the right.
Can you please give me any suggestions to repair this myself? Thank you.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top