Epson WF-7610 Blocked Printhead

Discussion in 'Printer Discussion' started by clockworksatan, Jul 24, 2020.

  1. clockworksatan

    clockworksatan

    Joined:
    Jul 24, 2020
    Messages:
    1
    Likes Received:
    0
    Hi all,

    I'm hoping someone can give me some guidance here. A while back, I stupidly placed a dehumidifier near to my printer (and herein lies a lesson, folks!) for a few hours, not realising at all that it was going to completely dry up the ink in its printhead.

    I've tried and tried to unblock the printhead by flushing cleaning fluid through it and running its self-cleaning process many, many times and have managed to get the black and cyan nozzles working properly, but the magenta and yellow ones refuse to unblock, and I'm starting to get really, really frustrated with it.

    I've been looking at videos on replacing the printhead and it doesn't look difficult to do - but before I do that I'm wondering if there's any way to remove the printhead and clean it manually, i.e. 'bathing' it in cleaning fluid/alcohol for a few days - or is it completely beyond repair if flushing it isn't working?
     
    clockworksatan, Jul 24, 2020
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.