Epson XP 3150 - Ink cartridge not recognized - Remains present

Jun 14, 2020
I'm going mad, please help.
The printer worked well with original Epson cartridges.
After replacing empty cartridges with a third-party 603XL, the printer worked fine for a few minutes.
Then the message "Ink cartridges not recognized" appeared on the printer's display.
The printer is not connected to the PC.
What I've done
1. Printer Memory clearing -- Cartridges removed, turned off, power cable unplugged, let rest for 15 minutes, turned on, turned off, cartridges reinstalled, printer turned on -- No Result.
2. Cartridge Chip resetting -- Reset all four cartridges with a chip resetter. The LED lit up briefly -- No Result.
3. Copper contacts -- On both the chip and in the printer they were clean, but cleaned nonetheless.
4. Consulted the Internet -- Not much wiser.
The message "not recognized" does not go away, remains and the printer refuses.
The empty original cartridges are unfortunately no longer available.
Also, the supplier of the third-party cartridges is no longer known, otherwise I would ask them. But attempts are being made to do so.
Please help, any advice is very welcome.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question