Epson xp 850 not printing after print head clean

Discussion in 'Printer Repair' started by Arthurh, Aug 13, 2017.

  1. Arthurh

    Arthurh

    Joined:
    Aug 13, 2017
    Messages:
    3
    Likes Received:
    0
    The print head head was removed to clean some stubborn ink clogs. After replacing goes thru pwr on sequence ok, but when clean inkjet selected, reboots and goes thru pwr up sequence agsin. Thisis the same for nozzle check and all print functions. Copy print etc. Could the firmare have been corrupted. If so how do I go about reloading the printef firmare again?
     
    Arthurh, Aug 13, 2017
    #1
    1. Advertisements

  2. Arthurh

    ruffin

    Joined:
    Dec 7, 2016
    Messages:
    1,001
    Likes Received:
    53
    Location:
    Florida, USA
    Arthur, firmware is not something to play with. Improper install can result in permanent damage to printer.
    Dont see how firmware was corrupted. Especially if printer was working ok prior cleaning. Be very careful here.

    Firmware available here:
    https://epson.com/Support/Printers/All-In-Ones/XP-Series/Epson-XP-850/s/SPT_C11CC41201
    Be sure your operating system is correct in small window at top of this download page
    Just click the .exe file with printer power turned on and printer connected to computer.
    Do not interrupt this install process.

    Might be better to first try re-install of printer using Epson install CD. You must first un-install printer.
    Should you be using Windows operating system, follow this:
    Control Panel -> Devices & Printers -> Right Click XP-850 Icon -> Select Remove Device
    Disconnect computer from Internet. Disconnect Printer USB connection until instructed to connect.
    Now proceed with printer re-install. Follow your Epson fold-out instructions for install process.
     
    ruffin, Aug 13, 2017
    #2
    1. Advertisements

  3. Arthurh

    ruffin

    Joined:
    Dec 7, 2016
    Messages:
    1,001
    Likes Received:
    53
    Location:
    Florida, USA
    ruffin, Aug 14, 2017
    #3
  4. Arthurh

    Arthurh

    Joined:
    Aug 13, 2017
    Messages:
    3
    Likes Received:
    0
    Arthurh, Aug 16, 2017
    #4
  5. Arthurh

    Arthurh

    Joined:
    Aug 13, 2017
    Messages:
    3
    Likes Received:
    0
    Thanks for the heads up. Must have done something wrong wrong on the install. Will retry.
     
    Arthurh, Aug 16, 2017
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.
Loading...