My Brother Printer is useless. Ain't Heavy and ain't my brother!

Joined
Jan 19, 2010
Messages
16
For you young snappers there was a song in my era "He ain't heavy, he's my brother." Well that surely dated me. :)

I have a fairly new Brother Printer
Brother MFC-J491DW [ec5c6831d77f]

I don't know why. Can't explain it but went to use it and it wasn't listed anymore. Always has been.

I have tried everything. New drivers. Full functional package. It was coming up with that error that ends in 709.

It seems to be okay with the fax part and installs it. Oh, important fact. It's always been wirelessly used. I guess it's loading the fax for wireless use? Who knows? I don't need fax.

It sees my printer when installing and searches for devices. I follow through the process and gets to FINISH. Still, it is not listed as a printer. And the report comes that important registry keys are missing/

I have searched, I have tried every suggestion. Watched videos until my eyes are bleary. I hate the ones where they don't speak. Pet peeve.

I don't know what to do. It's maybe over a year old. Used so rarely. 2x a month maybe? It's not worn out by a long shot.

Does anyone here have knowledge and recommendation of what to do besides pitch it?

As we all are for help, I would be most grateful for a solution. G'day jackdashack
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top