No IP address for printer - unable to register for GCP

Dec 8, 2017
Hello. I'm not tech savvy, but earlier this year, I managed to register a cloud printer (Epson XP 330) for use with my chrome book, using my phone as a hot spot. I had no connection problems for many months and printed often. A few weeks ago though, the printer started showing as offline when I attempted to print from my chrome book, even though it was on and my phone showed the printer was connected to the hot spot. I researched for a solution. When I tried to re-register the printer to Google cloud print, as suggested, and tried to get the IP address, it showed as "" or "none" between the two reports I printed. Tonight I actually bought a new printer (Epson XP-340). When I printed a status sheet, I also failed to get an IP address - it shows as unknown. As such, I could not proceed to register to Google cloud print, Could anyone please tell me what's wrong and how to fix the problem?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question