Epson printer can't get an IP address


Joined
Dec 15, 2018
Messages
1
Hello,

I've been trying to resolve this issue for several days to no success. I have Epson Stylus Photo PX720WD printer which has wireless capability. It was connected to my home network just fine, but after Virgin Media changed the router (and obviously SSID), the printer can no longer connect to the network wirelessly - it gets APIPA address 169.. I tried many times myself, also connected to Epson support, ISP support. They connected to my PC trying to resolve the issue, re-installing drivers etc. Nothing worked. No one could resolve this issue, and it's just giving me so much headache, as the printer had its own place at the wall across the room, there is no space for it next to my PC. Finally I had to connect it with the Ethernet cable and disable wireless, and put it underneath my desk which takes too much space and created inconvenience for me to sit. What on earth could happen to this printer, why it can't obtain an IP address on wireless? I restarted the router a few times, all other wireless devices are working fine, it's just the printer isn't. What can be the issue, if anyone experienced a similar problem? Any advice/suggestions would be highly appreciated.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top