p-touch not working on new PC

Apr 14, 2013
Hi, I have Windows 7 64 bit. My Brother p-touch QL-500 printer is USB connected.
My main hard drive, the C drive, is an SSD drive, just in case that matters.
My p-touch printer, which I use for address labels,worked OK until I installed it on a new PC, using the installation disk.The installation seemed to work OK, until I tried to use the machine. Then a message flashed up to say the drive was broken. I re-installed it from the Brother downloads page and it seemed OK.
Now I find that if I try to make an address label it's OK until I get to the part where I click on 'check media'.
Then a message flashes up to say 'printer offline or no media', neither of which is correct.
If I ignore the message and continue through to the print stage, nothing happens except that the green light on the machine flashes rapidly until I turn the machine off.
The label position-er or reset button works fine. Looks like a software fault but if I uninstall and re-install it makes no difference.On the Brother download site I notice, by the way, that when I plug in the printer details the driver I download is for Ql-550, not 500.
I'd be grateful for any advice.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question