Ricoh MP C2801 firmware update failed. Machine died

Joined
May 17, 2022
Messages
1
Hi Everyone.

I have a problem with my Ricoh C2801. I tried to update firmware using Ricoh firmware update tool, but it failed in the middle for the update for unknown reason. Now my machine is dead and says waiting for firmware update upon every reboot.
I tried to flash it multiple times with the official tool but no luck. I can see the machine in the tool and it seems to be available but can't flash it.

What I have tried so far:
1) Tried to downgrade version -> Error
2) Tried flashing using SD card.
- I copied all *.rfu files to SD card romdata folder,
- Renamed all *.fru files to *.fwu
- inside romdata I placed fru files into separate folders with names like D086 etc. (found that this is necessary form Youtube)
- Inserted SD card into second SD slot and turned on the machine.
- Nothing happened
3) From CLU.txt file I found some communication error related records and used Charles proxy to see what firmware update tool does. I found that it is trying to connect to printer over HTTPS port 443 and connection is getting refused. I was able to confirm the same using telnet from local machine. Seems like machine is not accepting HTTPS connections.
4) I found few videos on Youtube from Ricoh dealer and fro, comments it seems like in order to get firmware for SD flashing I need to be a dealer.

Question:
Can anyone please explain me how to get firmware for my machine and how to flash it using SD card.
Seems like firmware which the official update tool downloading is not suitable for SD card flashing.
 

Attachments

  • CLU.txt
    16.9 KB · Views: 6
  • detailed_info.png
    detailed_info.png
    33.4 KB · Views: 16
  • downgrade_failed.png
    downgrade_failed.png
    35.5 KB · Views: 16
  • fw_update_tool.png
    fw_update_tool.png
    284 KB · Views: 16

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top