Samsung M2835DW Lazerjet problem

Discussion in 'Samsung' started by Robertj298, Feb 16, 2018.

  1. Robertj298


    Feb 16, 2018
    Likes Received:
    My printer started acting up a couple weeks ago where when I tried to print I would get error messages. both in wifi and hooked up with a printer cord. I tried upgrading the drivers and software to no avail. The funny thing is after I hit the print button it takes 45 seconds before I get the error message but after I get the error message if I unplug the power at the printer and then plug it back in the page will print. Any ideas? Thanks Bob
    Robertj298, Feb 16, 2018
    1. Advertisements

  2. Robertj298


    Dec 7, 2016
    Likes Received:
    Florida, USA
    You dont indicate operating system
    If Windows, follow this:
    Control Panel -> Devices & Printers -> Right Click M2835 Icon -> Select Remove Device
    Now re-install printer driver either from Samsung Install CD or download from Samsung Web site
    Be sure to follow install instructions carefully. Some manufacturers require usb cable to be disconnected
    before installing driver.

    The idea here is to un-install previous install attempts before you re-install printer driver. One more thought, think it wise to use the Samsung install CD for printer driver. You may not have had quality connection with Samsungs WEB site
    Last edited: Feb 16, 2018
    ruffin, Feb 16, 2018
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.