Stylus Photo R2400: Light Show, No Go!!


Joined
May 4, 2020
Messages
1
We moved into a new house with all three printers packed in their OEM cardboard and styro. Several months passed....The two Canon printers were unpacked and started right up after several cleaning cycles and in one case a CIS tank and cartridge top up with deep cleaning cycle. Both work as new.
The medium format EPSON STYLUS Photo R2400 is another story. This one also has a working CIS system: I topped the 8 tanks, vacuum topped the cartridges and tried to run any and all functions both USB'd into two different computers MacBook Pro( OS High Sierra 10.3) and HP DV7 (Windows 7 Premium) with fresh driver and utilities downloads. I tried using just the bare printer itself.

I get a blinking RED JAM button and a blinking RED INK button every time I start the machine.

I have thoroughly searched for paper jam or scrap of paper, loose impediment, broken part...nothing.
I have repeatedly reseated all full cartridges in the carrier, I have repeatedly removed and replaced the paper in the back tray feeder.... nothing seems to work nor can I find any instruction in the manual to repair, INCLUDING the one about Shutting down, disconnecting USB, holding and releasing JAM button while turning machine on..... end result is always both blinking buttons.THANKS!!!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top