Workforce WF-2750 COPY error message: Paper source setting is invalid

Nov 26, 2021
This is an easy fix for Epson software and I wish they would correct this flaw. The problem is that there is no such setting in the SETUP menus. Now, you may THINK you have found it in SETUP/PRINTER SETTINGS/PAPER SOURCE SETTINGS. But no, it is not there (where it should be - maybe). The only way to affect this particular "paper source setting" is as follows:
When you have selected COPY/OK, there will appear in the display (for only about two (2) seconds!), "SETTINGS" with an "OK".
You must immediately (before the display window shows "START COPY") press OK again. Then you will get the elusive window SETTINGS/LAYOUT/BORDER or BORDERLESS. You must select BORDER. Now you can copy.
BTW, this secret menu also lets you select DOCUMENT SIZE, ZOOM, ORIENTATION, 2-SIDED, DRY TIME, and others.
I bet you didn't know that you could do all this stuff from the COPY function.
The reason I say this is an easy fix for Epson is that the software should allow more time (say, 15 seconds) for the secret menu offering after COPY is selected. In addition, the message could be worded so as not to lead the user on a wild goose chase in SETUP. Perhaps it should say "Border/No Border Setting is invalid".


Mar 6, 2023
This did not solve this problem. After picking No Border, when can you hit the BW Print button??

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question