Brother MFC-J6530DW Scanner Install/setup problems in Linux

Mar 1, 2019
The issues are:
1 Getting the scanner to work on computer 1 (printer works but need scanner of use with Xsane)
2 Getting the scanner to work on computer 2 . "Scan to file" for preference (printer and scanner not working scan to file for preference)

Set up
Printer. Brother MFC-J6530DW, Static IP address on network with two computers,
Computer 1 Lunix, Fedora 29 64 bit, Gnome desktop XCFE desktop also installed, Fixed IP address
Computer 2 Linux Fedora 28 64 bit Gnome desktop Fixed IP address

On machine 1

I used the Linux driver install tool from the Brother web site for the install of the printer MFC-J6530DW and scanner. After the install the printer would not print a test page or anything but the job would show as completed in CUPs. . It was found that an additional package had to be installed libstdc++ i686 version to get the printer to work. So the printer section works fine.

However I can not get it to scan at all in any form. I want in particular to set it up for "scan to file".
In looking into this I found today in Gnome log the following entries;

invalid rule /etc/udev/rules.d/65-brother-libsane-type1-inst.rules:14:unknown key SYSFS {idVendor}
invalid rule /etc/udev/rules.d/65-brother-libsane4-libsane-type1.rules:19:unknown key SYSFS {idVendor}

Cannot access vdagent virtio channel /dev/virtio-ports./.redhat.spice.0

io/hpmud/model.c 543 no hp_ther_mfc-j6530dw attributes found in /usr/share/hplip/data/models/unrelated/unrelated.dat
io/hpmud/model.c 532 no hp_ther_mfc-j6530dw attributes found in /usr/share/hplip/data/models/models.dat
io/hpmud/model.c 543 no ther_mfc-j6530dw attributes found in /usr/share/hplip/data/models/unrelated unrelated.dat
io/hpmud/model.c 532 no ther_mfc-j6530dw attributes found in /usr/share/hplip/data/models/models.dat

Glib-CRITICAL: g_child_watch_add_full: assertion ‘pid > 0’ filed
Process 27574 (xfdesktop) crashed in g_type_check_instance_is fundamentally_a()
Process 11763 (xfdesktop) of user 1000 dumped core. nl/nl =Stack trace of thread 11763:n/l#0 00007f3cf5a3e09,, (gord in to reference and,0
failed to start dnf makecache

Some of the above seems to be related to the scanner. How are the scanner ones fixed?

Setup and check
Checked configuration of brsanecionfig4
brsaneconfig4 -qa | grep -e Scanner
0 Scanner “mrf-j6530dw”
$ brscan-skey
$ brscan-skey -l
and got a messages the libnsl could not be found/
Installed libnsl
dnf install libnsl
Ran the command again and got;
Scanner brother4:net;dev0 : Active

When I try to scan anything using Xsane or simple scan the applications just hang looking for devices.

Computer 2

Then log is shown the following relating to the scanner.

invalid rule /etc/udev/rules.d/65-brother-brscan4-libsane-type1-inst.rules:9: unknown key ‘SYSFS{idVendor}

How do I fix this?

The brother web site drivers were installed using the tool avaibnale on the web site. It installed the printer driver and the scanner driver

When I ran brscan-skey -l I got a messages
Error loading can not open shared object file. no such file or Directory.

I then downloaded and installed libnsl and now when brscan-skey is run I get

MFC-j6530DW : brother4:net1;dev0 : Active

Set up scanner
sudo brsaneconfig4 -a name=Brother model=MFC-J6530DW ip=192.xxzx.zzz.yya
• Confirm it worked, and got the following output
$ brsaneconfig4 -q
Devices on network
0 MFC--j6530DW "MFC-J-6530DW"
Check Brscan-skeys
$ brscan-skeys
$ brscan-skey -l
MFC-J6530DW “MFC-J6530DW : Active

I try to run Xsane or simple c=scan and they hang looking for devices
Also if I try to set the printer “scan to file” function up in the printer’s web page I get an error when I try to test.
The folder on the computer machine which is to hold the scanned file has been set up with permission for all.
So in the Printer scan set up the path is entered as
// also tried
The web page saved the configuration and then asks for a test.
On Test The following error message is presented.
Server Timeout. This message will appear when you cannot connect to the server.
Make sure that:
*Your server address is correct
*Your server is connected to the network
*the machine is connected to the network
ECODE: 0x00002010, -32, 0x00001B5B
The computer IP address is correct
The printer Ip can be pinged from the server (computer 2) The printers internal web page can be displayed on computer 2 so the network is working and the devices are connected on the saem network
Any Ideas please?
I have looked at the web to see if there is any fix. While there may be and I am missing it I would appreciate any assistance that is possible. During the search on the web I can across sone sim links which were indicted as being required. These being as below
sudo mkdir /usr/lib/sane
sudo ln -s /usr/lib64/sane/ /usr/lib/sane/
sudo ln -s /usr/lib64/sane/ /usr/lib/sane/
sudo ln -s /usr/lib64/sane/ /usr/lib/sane/
sudo ln -s /usr/lib64/ /usr/lib/
sudo ln -s /usr/lib64/ /usr/lib/
sudo ln -s /usr/lib64/ /usr/lib/
So I set the following with no issues

sudo mkdir /usr/lib/sane
sudo ln -s /usr/lib64/sane/ /usr/lib/sane/
sudo ln -s /usr/lib64/sane/ /usr/lib/sane/
sudo ln -s /usr/lib64/sane/ /usr/lib/sane/

but the final three could not be found on the system or any other location. Where do I find the etc files and how do I install them?

At this point I am asking for help.

Sorry for the length og this but I could not see any other easy way to showe my issue.
Aug 5, 2020
What version of linux are you running?
If you're running the UFW firewall you have to set a rule to open port udp 54925 for the scanner and 6566 for the scan key. I can't remember which it is for the scan key, udp or tcp so maybe open both to try to get it working.
My biggest problem with the J6545DW is getting the document feeder scans to be both scaled and aligned correctly. I had an MFC-845CW and it worked pretty well in linux but I've never bothered to try to get the printer to scan to the computer (scan key), I've always initiated scans from the computer.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question