Canon 3rd party carts not showing empty

Joined
Oct 26, 2020
Messages
22
Details;
Canon ip4300 printer (new purchased a few years ago, just placed in service to replace the same model with maxed out waste ink pads.
Ink Owl auto resetable carts (no need for a chip resetter) PGI-5 & CLI-8)

Carts are replacing older 3rd party (that needed a resetter) where the sponges apparently dried out causing printing problems. So far I have had 3 carts go empty with no indication they were unlike the older carts which were always 'spot on' when it came to showing the ink reservoir levels. I contacted Ink Owl (upstate NYS) about the problem they reset themselves when they are removed form the caddy. One problem was I wasn't aware of then being auto resettable so I as I did the past 8-10 years 'reset' the carts before I filled them. I told them about my mistake and was told that shouldn't be a problem.

Has anyone come across this problem that the printer is not showing low ink levels? The indicator always shows full no matter what. All other printer functions are ok, no known issues.
 
Joined
Oct 26, 2020
Messages
22
Apparently, these ARC (Auto reset) chips are the problem as they don't show ink levels except for at least one new style that claims to show the levels. I found one on eBay and another (possibly the same chip) elsewhere.
I'm told the best solution is using Canon carts and just modifying them (drill a fill hole with plug).

I got those ARC carts from Ink Owl which I've done business before. Unfortunately they don't tell on this on their site which they should. They claimed they should show when they are out, but don't. I bought two sets, but after a couple of phone calls they are refunding my money.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top