Canon MP5750 printer

Discussion in 'Printer Discussion' started by AndrewR, Dec 4, 2019 at 4:39 PM.

  1. AndrewR

    AndrewR

    Joined:
    Wednesday
    Messages:
    1
    Likes Received:
    0
    Had a MG5750 printer. Worked OK with router wifi connection. Two weeks ago wifi icon in corner of screen went to a red cross. Tried everything to re establish a connection. Eventually could not solve the problem and decided the printer now 18 months old was at fault. Bought another MG5750 thinking that it would be OK but it looks as though I have wasted my money as this will not connect to wifi either. I uninstalled all the old software and reinstalled it but it just will not detect the printer. Spent a lot of time with BT checking the router and trying to connect by the WPS method. Also tried entering the SSID hub reference but still not working. So I am at a total loss why it will not work. Have you any suggestions?

    I use windows 10 and think I have up to date Canon drivers
     
    AndrewR, Dec 4, 2019 at 4:39 PM
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.