Epson Artisan 1430 printhead mixing ink

Feb 27, 2022
Good evening all,
My mom had an old Epson Artisan 1430 that had been sitting in her garage for a few years. They had stopped using it cause it ran out of ink and they thought ink was too expensive to replace.

I brought it home and hooked it up. And everything seemed to boot up without issue, so i ordered some new ink cartridges.

Everything registered fine, and a test print only Gave me magenta.

Ran a head cleaning. Nothing.

Tried the saturated paper towel trick. That freed up my cyan, but not a drop from the rest.

So I removed the printhead and tried rinsing out the ports with a syringe. - this cleared put all 5 colors, had a steady fan coming out of all the pinholes, except for black.

It was not giving me so much as an air bubble.

So I let the printhead soak in a cleaning solution, with a tube full of cleaning solution attached to the nipple of the black as well to soak it from both sides.

I just went to see if I could get anything through, and when I tried to syringe the black port, I got cleaning fluid blowing put the 2 adjacent ports (yellow and light cyan)

What would cause this?

I am guessing somewhere along the path something got dislodged and the three patches are merging, and then further blocked along the path..

Anything to do to bring this guy back from the dead???

Thanks in advance!!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question