Epson ET-2756 driver installation problems


Dec 28, 2021
Hi, not sure if this is the right forum since the problem is with the scanner part of this all-in-one unit.
The installation proceeds OK for the printer driver and then starts the scanner driver installation. It gets about half way through that section and then throws up an error: "Could not copy files. Make sure the target disk is not read-only". There only is a single disk in the laptop, and the installation files downloaded and extracted to that fine, so it certainly isn't read-only. I have tried this installation when logged in as a user, logged in as the administrator, running the installation file with administrator rights, even in "Safe Mode" but always get the same result. :mad:
To add insult to injury, after pressing "OK" on the error, the installation reports that it has been successful... but it hasn't. Half the functionality of the all-in-one unit, the scanner half, doesn't work!
Running the Epson Software Updater offers the scanner driver as a separate installation, but that reproduces the same error. :(
I have also tried the two fixes suggested here but they don't work.

Does anyone here have any ideas on how to fix the "Could not copy files" error or bypass it?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question