Epson WF-7620 - Won't recognise ink cartridge

Sep 11, 2017
Hey everyone,
The print quality on our WF-7620 wasn't very good so I tried running the nozzle head cleaning programme. It started to get better so I continued the nozzle head cleaning. After about 5 times of doing this, an error message has come up saying the printer doesn't recognise the black ink cartridge. I've tried taking the cartridge out and putting it back in again, turning the power off and on again, even putting in a new black cartridge, but this message is staying.

I wondered if there was a full system reset I could do on the printer but when I looked it seemed as if I could only reset the copier, wifi or fax data, not the printer as a whole?

Any advice would be much appreciated,

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question