Epson WF-7710 not recognizing cartridge

Discussion in 'Ink Cartridges, Toner and Refills' started by clif9710, Jul 25, 2020.

  1. clif9710

    clif9710

    Joined:
    Jul 25, 2020
    Messages:
    3
    Likes Received:
    0
    My WF-7710 will print fine for a week or so and then I get a notice that the yellow cartridge is not recognized. I then reseat the yellow cart. This may or may not work, often it will then tell me the other carts are not recognized. I reseat them all and this may or may not work. Eventually, many reseatings later, all the carts will be recognized and I am on my way.

    About a week or so later, the yellow is again not recognized. Frustrating? You bet! I carefully cleaned the tiny wire contacts with alcohol and did the same with the printed circuit contacts on the yellow cartridge. Given some time, again yellow is not recognized.

    I went out and bought a new Epson yellow 252 cart and installed it. All was well. Then, again the yellow is not recognized. This is Epson's own cartridge. I had a refillable yellow, popped it in and it is recognized, but I know it won't be for long.

    I just downloaded drivers for the WF-7710 from Epson. My fingers are crossed.
     
    clif9710, Jul 25, 2020
    #1
    1. Advertisements

  2. clif9710

    clif9710

    Joined:
    Jul 25, 2020
    Messages:
    3
    Likes Received:
    0
    Nope, the firmware update didn't fix it.
     
    clif9710, Jul 27, 2020
    #2
    1. Advertisements

  3. clif9710

    VA1DER

    Joined:
    Jul 11, 2020
    Messages:
    25
    Likes Received:
    3
    Location:
    Nova Scotia
    Sounds like dirty contacts on the interface with the cartridge chip. I have run into similar issues with my WF-3640 and WF-7720 printers, but I use refillable cartridges with sometimes questionable quality for where the chip mounts.

    It's a great workhorse of a printer - I would suggest checking out a chipless firmware mod. It's not expensive and if you do use refillable cartridges it makes that process a whole lot simpler.
     
    VA1DER, Jul 27, 2020
    #3
    clif9710 likes this.
  4. clif9710

    clif9710

    Joined:
    Jul 25, 2020
    Messages:
    3
    Likes Received:
    0
    I thought so too, but repeated cleaning of the contacts on the printer and on the cart had no effect.

    Thanks very much for the firmware link. I've installed it and after clearing up a problem with getting through the licensing procedure hope it solves the problem for all time!
     
    clif9710, Jul 28, 2020 at 1:27 AM
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.