ET-2650 ecotank leaves middle of the page blank


Joined
Mar 17, 2021
Messages
1
Hi! The support lady I contacted is unable to help me, and suggested to take it somewhere to get it checked. Has any of you ran into this problem before, know a fix without repairs?

Last weekend my prints were flawless, but all of a sudden my printer decided to leave 1/3 of the document blank, the middle part to be spesific. Just a big blank bar going from the top of the page to the bottom, but the sides print just fine.

*My printer is up to date, checked with both the Epson's software updater program and from the printer itself, via settings.
*All types of documents show the same results, both monotone and color, no matter the size settings.
*I've run the settings to clean the uhh.. printer heads?, and done the realignment. Restarted the printer after both of those.
*Copies print as normal, as well as the test pages and realignment sheets.
*I use Epson's own programs.
*I've used this printer for a year without issues.

If no one has any solutions, i guess i have to resort to the repairs, but I'd really, really rather not..
 
Ad

Advertisements

Joined
Mar 16, 2021
Messages
5
I am having the same issue. Epson support gave me instructions to update the driver which they said should fix the problem but it didn't. Will call them back tomorrow and I hope they have an alternative solution to taking it to a repair shop because that can get pricey. Good luck to you!!
 
Joined
Mar 18, 2021
Messages
2
Don't take it to the repair shop, multiple reports of the same issue - I have the exact same problem, I believe its driver related, as when printing through the XPS doc viewer provides a perfect print. Similarly if you manually create a word doc with the page a the same size it does the same thing, However I believe you and I are talking about what happens when you right click and print via the contextual menu? all photos print incorrectly.

I have uninstalled all aspects of the drivers and reinstalled with upto date fresh drivers and it is still presenting the same issue, I'm not sure why but I will keep you posted if I find a fix - its something to do with the print service windows uses and the printer.
 
Joined
Mar 18, 2021
Messages
2
So an update,

"It sounds as though it is in relation to the photo viewer printing, this is a known problem by Microsoft in relation to that glitch there in not printing the full image as it shows in photo viewer to your printer, in the meantime you can print using another program on your computer such as paint or you could use Epson Photo + if you do have that installed." - Verified known fault by Epsom customer services.

checking with Microsoft they have advised uninstalling the march updates to revert back to a working built while it is being fixed. As an easier less tech savvy approach you can print to the Microsoft XPS device listen in printers, this produces something similar to a PDF - which you can print perfectly fine from. (Currently how I am doing it)

Hope it helped! its not your machines.
 
Joined
Mar 16, 2021
Messages
5
Don't take it to the repair shop, multiple reports of the same issue - I have the exact same problem, I believe its driver related, as when printing through the XPS doc viewer provides a perfect print. Similarly if you manually create a word doc with the page a the same size it does the same thing, However I believe you and I are talking about what happens when you right click and print via the contextual menu? all photos print incorrectly.

I have uninstalled all aspects of the drivers and reinstalled with upto date fresh drivers and it is still presenting the same issue, I'm not sure why but I will keep you posted if I find a fix - its something to do with the print service windows uses and the printer.
Thank you for this information and for anawering so promptly. My husband was able to get a normal photo to print with the program on our Canon printer, which we use to print out documents. There is an option to use the Epson printer which we usually ignore but he was successful using it. This will confirm your theory on what is actually the issue. I will be contacting Epson support today to inquire about this. Will let you know when I get some further information.
 
Ad

Advertisements

Joined
Mar 16, 2021
Messages
5
Epson support confirms that they are aware of the problem and are working with Microsoft to fix it.. They suggested that I check the Epson website periodically as they will be posting updates regarding the situation. Hope this helps!!
 
Joined
Mar 18, 2021
Messages
1
Well gee I am glad I found this thread, as I started having the same problem a couple days ago! I spent at least an hour on the phone with Epson support and they had no clue! So thank you for those who answered here. I like using the photo viewer wizard as I can get multiple images printed to one page, so going through the regular microsoft photo viewer I can only print one image at time, and as artist, this is very troubling. Hope they get it fixed soon!
 
Joined
Mar 23, 2021
Messages
1
Thank god I found this forum, I was about to go insane, I've done nothing but realigning, nozzle checking, head cleaning and printing. I've been trying to look around to delete the March update, though, but it seems to not be a thing, as well as Epson not addressing the situation on how to fix it.
 
Ad

Advertisements

Joined
Mar 23, 2021
Messages
1
Thank you for this information and for answering so promptly. My husband was able to get a normal photo to print with the program on our Canon printer, which we use to print out documents. There is an option to use the Epson printer which we usually ignore but he was successful using it. This will confirm your theory on what is actually the issue. I will be contacting Epson support today to inquire about this. Will let you know when I get some further information.
My problem is that my EPSON XP 820 is fine printing text but when I try to print photos (on any paper) they come out with crisp edged white stripes of various width. Is this what others have experienced?

Please make your answers easy to understand. Is Epson going to fix this? When? Or can I fix it? HELP PLEASE
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top