Invalid Cyan Toner - Any advice greatly appreciated!

Jul 18, 2014
So I have a Samsung CLP-310 laser printer. A few years back I needed new toner for the first time, so I bought a refill kit, plus the chips which reset the counter. No problems at all. Last month, my toner ran out again. So I got another refill kit, and did the same. However, this time round there was an error message: Invalid Cyan Toner.

Ok, so I assumed it was just a dodgy batch of Cyan toner. Rather than going for a new refill kit, I just bought a new cyan toner cartridge. But to my surprise, I received the same error: Invalid Cyan Toner. I thought it must just be bad luck, getting a dodgy toner cartridge also. So I sent it back, and got another brand new cartridge. Predictably: Invalid Cyan Toner.

So now I know that the toner isn't actually the problem. Something in the printer is malfunctioning causing this error. The startup code with the lights shows a red on Cyan for 1 second, and then full reds across the board. The Samsung tool on the PC gives the error message above. I have tried:

1. A full, comprehensive printer clean, getting out every last scrap of used toner
2. A complete clean of the Cyan cartridges I have
3. Changing all toner cartridges, not just the Cyan

Nothing works. The only thing the printer will do is print a diagnostics page using black toner. It does absolutely nothing else. If it makes any difference, my machine was purchased in the UK, and the toner I purchased was from Germany.

Any suggestions or advice to repair this asinine machine will be hugely appreciated! Thanks.
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question