MFC J430W scan issues in network connected devices

Discussion in 'Printer Discussion' started by emanam, Aug 24, 2017.

  1. emanam

    emanam

    Joined:
    Aug 24, 2017
    Messages:
    1
    Likes Received:
    0
    We have a small network consisting of a server and some windows laptops. The connection is p2p. The printer is connected to the network using wireless connection and static ip is assigned.

    I cannot scan using the printer on any other devices connected in the network but can successfully print with it. I also checked scanning documents using usb connection and it worked.

    There's also an issue where i don't always see scan options on the printer when i right click it on devices and printers. It was there when i first installed it but it doesn't show now. I can however see it in imaging devices in device manager
    I installed the printer using brother full package software , When i open control center and press scan , the window gets stuck and hangs and later shows with a message "failed to connect to the device".

    Are there any other ways to solve it . I tried on windows 7 and 10 but had no luck.

    If there's anything else that i am unclear about , please ask.

    thank you
     
    emanam, Aug 24, 2017
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.