Brother DCP-T420W — no proper macOS drivers/support?


Joined
Feb 28, 2021
Messages
1
Hello,

I need help with my Brother DCP-T420W.

I am a macOS Big Sur user and it seems that Brother does not want to release macOS drivers for this printer. They want users to save files to PDF and use the iPrint &Scan app to print files. This is so funny, and so annoying.

Screen Shot 2021-02-28 at 5.35.38 PM.png


I would like to install the printer natively on my Mac.

Does anyone know any workaround to this problem?
 
Ad

Advertisements

Joined
Feb 17, 2021
Messages
2
I've got the same prob with my Brother HL5370DW. :( Here's a workaround I found but haven't tried because it's beyond my ability at the moment:

What worked: I read the error logs on my printers. They pointed me to permission problems with /usr/libexec/cups. Perms should be 755.


To make this work:



System Integrity Protection should be disabled.
  • You must be a sudoer or have root permissions.

Instructions


Open a terminal.


  • cd to /usr/libexec
  • sudo chmod -R 755 cups

That's it! Printing with older drivers works now! AirPrint works. The scanners work. Apparently Apple screwed up the perms on the cups directory that makes printing work when they created their protected filesystem! Urrgghh! This should work with all older printers regardless of brand.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top