Epson wf nozzle problems

Discussion in 'Printer Repair' started by nalah, Oct 12, 2019 at 10:09 AM.

  1. nalah

    nalah

    Joined:
    Saturday
    Messages:
    1
    Likes Received:
    0
    Hi - any ideas on this one.
    Have an Epson WF 2660 that showed all 4 nozzles were pretty blocked when I ran a nozzle test. I ran the clean nozzle process a couple of times which only showed a small improvement. I then used a syringe to carefully wash out each nozzle. Plenty of gunk came out. When the liquid came out clear, flushed with distilled water replaced the cartridges and ran test page - got no print at all, absolutely nothing. Also got a message that the nozzles may be blocked. Removed the cartridges again and used the syringe again to check if the nozzles would pass liquid - no problem water flowed through all the nozzles fine. But again when I replaced the cartridges no print at ll.
    Anyone any idea what has happened

    thanks !!
     
    nalah, Oct 12, 2019 at 10:09 AM
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.