SX200 scans but doesn't print (Windows 10)

Oct 15, 2017
I've used my SX200 for over a year with Windows 10, but it has recently stopped printing. The scanning function works fine, but when I try to print a document I get the usual happenings on-screen, the printing preferences screen is available as usual, the document appears in the print queue for a few seconds, and then ... nothing. From the screen it appears as if the printing has been done, but the printer just sits there quietly and does nothing.

I've tried removing the device and re-installing. I've tried updating the driver but I am told it is up to date (version 6.64). I know the printer itself is working, as I can use it succesfully under Windows 7 on an old laptop. Any ideas please on how I can get it to work under Windows 10 again (currently on version 1607, OS build 14393.1715)?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question