Brother MFCJ6930DW - Cannnot Detect

Sep 11, 2020
Hello All,

A year ago, I purchased a Brother MFCJ6930DW. I used it one time to test that it worked and put it back into storage. Of course, a year later (after the warranty has expired) I took it out of storage to use, but it has been giving me a headache.

When I insert the Brother Starter Ink, it repeatedly tells me to use genuine brother ink and shows “X” on the cartridges. I have tried with no success, using electrical tape and a black sharpie to block the clear ink window on the ink cartridges. I have bought after market ink cartridges and it tells me that it “cannot detect and to reinstall firmly”. I have also tried bypass methods I’ve seen on YouTube.

What could be the problem? I don’t want to spend $70 on new cartridges and end up its not the problem.

Any suggestion would be greatly appreciated.

Thank you!

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question