Epson Workforce 840 - new/replacement print cartridge not recognized

Discussion in 'Printer Repair' started by front desk printing, Mar 2, 2020.

  1. front desk printing

    front desk printing

    Joined:
    Mar 2, 2020
    Messages:
    1
    Likes Received:
    0
    Hello,
    I hope someone can help. My Epson WorkForce 840 printer was working perfectly well until a week or so ago when I replaced the black ink cartridge as prompted by the machine. I'm using only Epson brand ink cartridges.

    Installing a new cartridge seemed like a breeze - old one was easy to remove & new one fit in perfectly and the cover of the cartridge chamber closed and snapped in place.

    But once that new cartridge was installed, the printer began saying it didn't recognize the print cartridge. Then it told me the color ink supplies were low & needed replacing also. I did that...

    Now the display window flashes on and off and gives me the message "A printer error has occurred. Turn power off, then on again. For more details see documentation or Epson.com."

    We already tried the turning off, then on. Unplugging power and connection to the computer.

    We may just buy another printer but if there are some steps I can try to clear this error pattern, I'd like to give it a shot. I once got forum help for an HP printer which solved the problem. I had to take out the formatter board and bake it to reactivate the soldering. It worked like a charm.

    On the other hand, in my current position, I can't devote too much time to this. Thanks in advance for any suggestions!

    front desk printer
     
    front desk printing, Mar 2, 2020
    #1
    1. Advertisements

  2. front desk printing

    JamesWF3620

    Joined:
    Mar 24, 2020
    Messages:
    2
    Likes Received:
    0
    Did you just update the Epson software?
     
    JamesWF3620, Mar 25, 2020
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.