Failing to print complete documents

Discussion in 'Epson' started by martinlest, Sep 23, 2017.

  1. martinlest

    martinlest

    Joined:
    Sep 23, 2017
    Messages:
    3
    Likes Received:
    0
    I have had a good number of relatively expensive printers over the past several years, all of which lasted very little longer than their warranty period before breaking down. So I went back to this old Epson I had in storage. I had to use it in Windows XP, as there are no drivers for later O/Ss, but for a couple of years it worked fine.

    Now however, when I try to print a (let's say a single-page) document, pretty much the same thing happens every time: The printer pulls the paper through and ejects it without printing anything. It then takes another sheet and prints the first inch or so just fine, then ejects that paper as well. It will then print several pages containing random (Greek etc.) characters..

    Seems to me, expert as I am NOT, that the problem is with the communication rather than the hardware (?), though I don't have any other WinXP machine to test that on. I uninstalled all the software, disconnected and reconnected and reinstalled the software (basically driver and Status Monitor), but exactly the same thing happens.

    Anyone able to help me get the printer back online? Thanks!
     
    martinlest, Sep 23, 2017
    #1
    1. Advertisements

  2. martinlest

    ruffin

    Joined:
    Dec 7, 2016
    Messages:
    1,001
    Likes Received:
    53
    Location:
    Florida, USA
    Random Greek characters???? Are you sure you have the correct printer driver?
    You dont indicate which Epson printer you have, but visit this site and download
    correct driver for Win XP for your model printer:
    https://epson.com/Support/sl/s
     
    ruffin, Sep 23, 2017
    #2
    1. Advertisements

  3. martinlest

    martinlest

    Joined:
    Sep 23, 2017
    Messages:
    3
    Likes Received:
    0
    Random Greek characters?

    No, they are as I say random - it's not Greek per se, but the kind of gibberish printers are wont to spew out when there's a problem like this.

    Sorry, the printer is a Stylus Color 680. Served us well for more years than I'd care to say!
    I already have the latest drivers installed (now uninstalled), but that makes no difference. (Same drivers that used to be working just fine BTW).

    Thanks.
     
    martinlest, Sep 23, 2017
    #3
  4. martinlest

    ruffin

    Joined:
    Dec 7, 2016
    Messages:
    1,001
    Likes Received:
    53
    Location:
    Florida, USA
    Ok, since printer was in storage for lengthy period, perhaps USB cable not making good contact
    due to corrosion. Try plugging USB in maybe ten times or more at both ends. If no improvement try
    new USB cable. Bad or intermittent connection would result in good print at times and no print
    at times (as you have indicated). Does printer show-up in Windows XP computer. Since printer prints ok at times, then printer driver probably ok. Let us know
     
    ruffin, Sep 23, 2017
    #4
  5. martinlest

    martinlest

    Joined:
    Sep 23, 2017
    Messages:
    3
    Likes Received:
    0
    Hi. Actually, I mislead you (sorry!) - the printer wasn't used much but it wasn't exactly in storage; it was in a spare room connected to an old PC.. and I did use it every so often. When my previous printer broke down, I used it as my sole printer for several months and it was fine.
    I have disconnected and reconnected - but maybe I can try a different connector. Yes. it shows up in XP as default printer.
    Thanks!
     
    martinlest, Sep 25, 2017
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.