HL-L8350CDW printer won't print after power failure-interrupted firmware upgrade

Jul 19, 2018
Hi, all,

I tried updating the firmware on my HL-L8350CDW printer and in the midst of the update, the power went out for a second. I was updating the firmware through the web based management tool. Subsequent attempt said the firmware was already up to date, however, the printer would not print (via wifi or a USB connection). The green data light merely flashes and the control panel buttons become inoperable whenever a print task is sent to print.

Checking firmware versions, the device is at MAIN 1.21, SUB1 **** (or blank), and SUB2 1.00.

Running a ROM checksum diagnostic in maintenance mode outputs: MAIN CheckSum OK, SUB1 CheckSum NG.

I've tried using the firmware update tool provided by Brother on both a Mac and a PC to update the firmware, but the tool reports that a connection cannot be made with the device when it starts the upload process (first steps collecting data from printer seem to work okay).

I've tried using Cauldron Dev's Oh Brother tool to download and upload firmware to the device, but it won't upload the firmware claiming the firmware on the device is up to date.

Any ideas on how to restore the function of the printer?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question